DreamSDK

DreamSDK is a modern, ready-to-use environment for the Sega Dreamcast development, designed for the Microsoft Windows platform.

Get Started

Download DreamSDK now!

Before running the installation of the DreamSDK environment package, please install the required prerequisites: Python 2.7 (32-bit), Git and the Subversion Client. Also, please note that you will need an active Internet connection to complete the installation.

Speaking about the hardware side, you optionally will need a retail (i.e. a regular) Sega Dreamcast and a Coders Cable, a Broadband Adapter, a LAN Adapter, or even no hardware at all if you plan to use a Sega Dreamcast emulator (like nullDC, Demul...).

Fast & easy to install

Just double-click on the setup file and let the program install & configure everything for you.


Ready to use

All the required toolchains (for the SuperH & Yamaha AICA) are already prebuilt and ready-to-use.


Lightweight

Thanks to the MinGW/MSYS environment, the space used on the disk is minimal.


Configurable & upgradable

With the included DreamSDK Manager tool, manage DreamSDK components really easily.


Respectful of the standards

DreamSDK is 100% compliant with the KallistiOS standards and documentation.


How to get some help?

Forums


Post a message on the DCEmulation forum if you need help on Dreamcast programming.

Help File


Download now the help file of DreamSDK. This file is of course included in the package.

Email


Send an email if you have a question on the DreamSDK package itself.

Python 2.7


Please install the Python 2.7 32-bit runtime, as that runtime flavour is linked to the GNU Debugger (GDB) binary for the SuperH architecture (i.e. sh-elf-gdb).

If you want to install the Python 2.7 64-bit runtime on the same computer, please do the following:

  1. Install the 64-bit runtime first, and install it in a separate directory, e.g. C:\Python\2.7\x64\. Add it to the PATH variable by using the proper option in the Customize Python page. This Python installation will become the default Python runtime.
  2. Start the 32-bit Python installation, and install it another location, e.g. C:\Python\2.7\x86\. At the Customize Python page, unset the Register Extensions option, like below.
  3. You have now both 32 and 64-bit Python runtimes installed.

Download Python 2.7 Close

Git


You need to install the latest Git on your computer, it can be either 32-bit or 64-bit, depending of your Windows version.

You can also install optionally TortoiseGit.

Note: If you want to install DreamSDK on Microsoft Windows XP Service Pack 3 (SP3), please download Git 2.10.0 and optionally TortoiseGit 1.8.16.0, as they are the latest versions supporting Windows XP.

Download Git Close

Subversion Client


You need to install the latest Subversion Client (SVN) on your computer, it can be either 32-bit or 64-bit, depending of your Windows version.

Note: If you want to install DreamSDK on Microsoft Windows XP Service Pack 3 (SP3), please download Subversion Client 1.7.19 from CollabNet, as this is the latest version supporting Windows XP.

Download Subversion Client Close

Internet Connection


You need to have an active Internet connection in order to install DreamSDK.

The Internet connection is used at the end of the installation process to download some required components, mainly KallistiOS.

Please be sure to have access to Internet while installing DreamSDK.

Close

Credits


The DreamSDK package was possible thanks to:

Also thanks to these individuals (in no particular order): japanese_cake, Manu/Le Panda, JMD, |darc|, Shendream, patbier, edd, Manic, zouzzz, and all the rest I forgot, sorry for this in advance!

The Grayscale Theme was made by Blackrock Digital.

Dream continues since almost 20 years! Wow...

Close